Java

古いJDKのモジュールを探す

JDK(J2SE)をダウンロードしようとしたら、公式サイトからは最新版へのリンクしか見当たらない。

というか、古いモジュールのダウンロード先が見つけれなかった・・・。

時代的に、もう Sun ではなく Oracle ですしね。

今回、JDK 5.0 Update 13 ではなくて、JDK 5.0 Update 9 が欲しかったので、必死に探してみたらありました。

JDK 5.0 Update 10 から、JNI 実行時のエラーメッセージの内容が変更になっているらしいので、それ以前のバージョンで試したかったのですよねぇ。